KB0054 - Add-in could not be loaded error after upgrading Microsoft Office

Affects

Microsoft Outlook + OnePlaceMail

 

 

Issue

You have previously installed OnePlaceMail in Outlook 2007 and you perform an in-place upgrade to Outlook 2010. You uninstall OnePlaceMail and install the Outlook 2010 version of OnePlaceMail, however, OnePlaceMail Outlook addin fails to load after the upgrade.

After adding the VSTO_SUPPRESSDISPLAYALERTS environment variable and setting it to '0' following the instructions in this kb article you receive an error message similar to the below when starting Outlook:

 

0054a

Solution

The reason is that the OnePlaceMail Outlook Addin is trying to load using the incorrect version of the .Net Framework. Outlook 2010 has prerequisite .Net Framework of .Net 4 which is greater than Outlook 2007. As Outlook 2007 was installed previously there is a registry entry telling the VSTO framework to load the OnePlaceMail using the wrong version of the .Net Framework. The solution is to:

  1. Shutdown Outlook.
  2. Locate the VSTO registry key for the OnePlaceMail Outlook Addin under HKEY_Current_User\Software\Microsoft\VSTO\SolutionMetaData. There will be a key with a guid for each VSTO addin similar to the below which is still trying to load the OnePlaceMail Outlook Addin with the wrong version of the .Net Framework.

 0054c2

 Delete the key that corresponds to the Guid of the OnePlaceMailOutlook Addin and restart Outlook 2010.

0054d

 

 3. Restart Outlook (the delete key will be recreated)

Related Links

Posted in OnePlaceMail